vsix file won't run
Problem reported by Valerie Masin - July 1 at 11:10 AM
Submitted
I recently upgraded to VS2017 and at that time uninstalled VS2013. I then downloaded the GhostDoc vsix file (GhostDoc.v2019.1.19150.VS2017-VS2019.Extension.vsix) but when I double-click it nothing happens.
I saw I still had some GhostDoc file installed from the earlier version and uninstalled that. But it didn't help.

2 Replies

Reply to Thread
0
Misha Zhutov Replied
Employee Post
0
Valerie Masin Replied
No, nothing on that page applies. I then googled and found other suggestions. Finally found one that worked, which is running VSIXInstaller.exe from the command line.

I looked in the registry to see what the .vsix extension is mapped to and it is C:\Program Files (x86)\Common Files\Microsoft Shared\MSEnv\VSLauncher.exe. If I run this from the command line, as expected, it behaves the same way as when I double-clicked it. I will remap the vsix extension to  VSIXInstaller.exe.

Thank you for your prompt reply. It reminded me to look into the install program itself.

Reply to Thread